Knowledge Base
HOME » KNOWLEDGE BASE » FORUM

ExpLoRer Board Not Joining TTN?

Hello,

I'm working through the LoRaWAN Academy using the SODAQ ExpLoRer Board, and I'm having an issue activating the device via OTAA on TTN.

I followed the steps one-by-one and I can't seem to get the device to join the network. I've added the required libraries and uploaded the TTN DeviceInfo sketch to obtain the DevEUI. I then created an application in the TTN Console and I used the DevEUI to register the device to the network.

Then, I uploaded the SendOTAA sketch from the TTN library, ensuring that I changed the loraSerial, debugSerial, and freqPlan parameters to their required values. Prior to uploading the sketch, I then copied the AppEUI and AppKey from the TTN Console and pasted these in the correct area of the sketch.

When I uploaded the sketch, the serial console states:
"Join not accepted: denied Check your coverage, keys and backend status"

I ran the DeviceInfo sketch again and noticed that the AppEUI value had been updated to match the AppEUI from TTN Console.

Any ideas why I am not able to authenticate this device with TTN? Thanks in advance for your help!


Image Attachments
TTN_OTAA_Error.PNG
Avatar
Hi,

Did you check coverage ? If you own a gateway, does your JoinReq appears in the gateway log page ?
Does this require a TTN gateway? I have other active gateways on hand, but they are not currently configured to send packets to TTN network server.

I understand the necessity for a gateway, but I'm confused because the LoRaWAN Academy makes no mention of requiring or configuring a gateway during the setup for the project. The project states that the only device required for this project is the ExpLoRer board itself.

This is the video/course I'm referring to:

https://lora-developers.semtech.com/resources/lorawan-academy/courses/getting-started

Laurens doesn't seem to mention a gateway during the setup process nor is the requirement for a gateway mentioned any in the previous course material.
Avatar
Hi, you do not need to connect a gateway to TTN if you are in a range of another TTN gateway. Do you have other devices connected to TTN ?

Anyway, you should connect one of your gateways to TTN at least to understand what is happening.
Olivier,

The area of Texas that I'm located in has limited availability for public TTN networks. I can spend some time setting up packet forwarding on one of our non-TTN gateways, but I'd also like to identify the correct way to configure the device to TTN without having to use a work-around. Nevertheless, I appreciate you taking the time to reply and address my concerns!
Olivier,

I followed your suggestion and configured one of my gateways to forward packets to TTN. I have confirmed that this gateway is connected through TTN console.

I then attempted to join my device to the network using the SendOTAA sketch. After uploading the sketch, I checked the serial monitor again to verify connectivity, and unfortunately I received the same error message:

"Join not accepted: denied
Check your coverage, keys and backend status."

Despite this error message, I noticed that the device showed as connected in TTN console for a brief period of time. However, when I try to send a temperature reading, no data is flowing through, and I only see the join acknowledgement in TTN with no temperature payload coming through.

Any ideas how to proceed?
Avatar
Does your JoinReq appears in the gateway log page on TTN website ?
If so, can you see the downlink in the same page, and you gateway logs ?
Previously, I could not see anything in the gateway traffic log, but I tried again this morning and was able to see the JoinReq in TTN console. There is no downlink data available.

However, besides the JoinReq, I am still unable to see any message being sent from the device or being received by the gateway. Looking at the device in TTN, it still shows 0 frames up and 0 frames down.

Additionally, even after I have confirmed that bot the gateway and device are online and confirmed that I can see the JoinReq, I don't see any JoinAccept messages on the gateway. Serial monitor is still showing the JoinReq is denied with the same message "Check your coverage, keys, and backend status."


Edit: I'm not sure what I did different, but data seems to be flowing through correctly now? I didn't do anything different, just tried flashing the SendOTAA sketch again (probably the 5th or 6th time) and all of a sudden it seems to be working? Not sure what fixed it since I didn't change anything but I'm very appreciative of your help!
Avatar
Ok, great to know that it is working.

Maybe you should avtiave verbose upload messages. In Arduino IDE: File->Preferences->Tick "Show verbose output during upload."
Of course, just as soon as I saw some success I'm back to square one.

Yesterday, I reviewed the gateway traffic on TTN console and I was able to see JoinReq and JoinAccept messages for my device. However, even though the TTN console indicated that I successfully joined the network, the serial monitor was still showing me the same error message "Join not accepted: denied. Check your coverage, keys, and backend status." I can verify that my keys are correct, and it appears there are no issues with TTN backend, so that leads me to believe it's some type of issue related to coverage.

Additionally, I am trying to send a temperature payloads but only a couple of the messages came through despite the JoinAccept. At one point yesterday, I did receive a couple of temperature payloads, yet the serial monitor still showed that the JoinReq was denied. Now today, I am seemingly back at square one because I cannot consistently get the device to join the network. TTN says my device is online, but FramesUp still reads 0.

Is it possible that I'm experiencing unreliability because the gateway and device are attempting to communicate on different channels?
Avatar
You should not experience frequency issues as gateways, if well configured, listen to all LoRaWAN frequencies.
Could you please post your code, TTN application & device configuration screenshot and the gateway configuration JSON file ? (remember to obfuscate keys)

Do you see the joinAccept in your gateway log (not TTN, but from the gateway) ?
I've attached screenshots of the sketch I uploaded, most of which was already created through the TTN library or copy/pasted from the LoRaWAN Academy.

I've also attached the serial monitor outputs after I upload the sketch, in addition to the device configurations (forum doesn't support non-image files).

I will follow up with gateway config details later today.
Image Attachments
ExpLoRer_SendOTAA_Temp_Sketch_1.PNGExpLoRer_SendOTAA_Temp_Sketch_2.PNGExpLoRer_Log_1.PNG
Additional screenshots.
Image Attachments
ExpLoRer_Log_2.PNGExpLoRer_Log_3.PNGExpLoRer_Log_4.PNG
Gateway configuration.
Image Attachments
gateway_conf.PNG
Got this issue fixed?
Avatar
Hi Collin,

You might have a frequency issue, could you please confirm that your gateway has 8 channels configured to respect the following frequency plan ?
https://www.thethingsnetwork.org/docs/lorawan/frequency-plans.html#us902-928
     Vcc issues ››